Search Results

Search results 1-20 of 167.

  • User Avatar

    Thanks for your answer. When enabling FT5x06 driver in kernel the device will be found and /dev/input/event0 will be created. cat /dev/input/event0 will display no results - surely because the driver does not support the M12 touch. When trying to use the EDT-FT50x6 driver that supports the M12 device I'm not successful. There is no /dev/input device created. Here my changes inside the device tree (inspired by efusa9x.dts): Source Code (12 lines) Thanks for any idea.

  • User Avatar

    Hi, try to use substitude all , with . in your configuration (e.g. 192.168.1.33 not 192,168,1,33).

  • User Avatar

    Dear support-team, for testing we have a ETM0700G0EDH6 display with capacitive touch controller. The supplier is providing a patch file for drivers/input/touchscreen/edt-ft5x06.c. The patch is for a different kernel version 4.13 and does not fit out of the box for kernel 4.1.15 V3.1. So I tried to apply the changes manually but the devices still is not working (no ic2 device 0x38 detected with i2cdetec). Inside device tree I'm using CONFIG_ARMSTONEA9_CAPTOUCH_FT5x06 configuration. The edt-ft5x06…

  • User Avatar

    Here my /drivers/tty/serial/imx.c.

  • User Avatar

    I decided doing it the last way and checking for a "linux,rs485-enabled-at-boot-time" inside the device tree uart definition (e.g. like the atmel or omap drivers are doing this). If anybody is interested I can send the modified drivers/tty/serial/imx.c file without warranty (it's working for me). I was not able to attach the file directly to this post. How to do this??

  • User Avatar

    No idea? It's getting urgent.

  • User Avatar

    Thanks for answering. I got it working while booting in u-boot. The time between the kernel muxing the pin to UART and my firmware is starting still is too long. So I muxed the pin to GPIO in device tree too. Now the pin is low while complete booting and kernel starting. The problem now is how do I remux the pin to UART in my firmware before opening the UART. If I leave the pin as GPIO the UART is working without the RTS signal only. Are there functions for remuxing the pins at runtime? Is there…

  • User Avatar

    Thanks for that explanation. But what does it mean for me? So I guess what to do now is adding something like this to board_init in u-boot:Source Code (10 lines) And do I have to control this pin manually in kernel startup again or does the kernel leave the state as it was set by u-boot?

  • User Avatar

    Seem to make no difference. Any other idea?

  • User Avatar

    RTS seems to be high while booting because on UART with RTS/CTS this will indicate the receiver is not ready. What if I would change the following device tree configuration Source Code (13 lines) to Source Code (13 lines) If I understood the documentation correctly this would enable a 100kOhm pull down instead of a 100kOhm pull up. Could this help without messing up the whole configuration/functionality? Or is there a better way to ensure MX6QDL_PAD_CSI0_DAT17__UART4_RTS_B to be low while bootin…

  • User Avatar

    Dear support-team, we're using armstoneA9 ttymxc3 for RS485 (Modbus RTU). We have connected RX/TX to R/D as well as RTS to enable RE/DE on a SN65HVD10 transceiver. It's working perfect but while booting sequence. The problem seems that while booting the RTS is enabling driving the bus lines on the transceiver. This will disturb communication of all other devices for some seconds. How can I invert this RTS line while booting on U-boot and inside the kernel so that the driver will be disabled? Tha…

  • User Avatar

    Dear support-team, when I try to rotate the screen content (180°) on armstoneA9 by:Source Code (1 line) nothing happens. Writing a 1 (normaly will rotate by 90°) is flipping the screen vertically. A look into /drivers/video/fbdev/mxc/mxc_ipuv3_fb.c is showing why this happens: Source Code (1 line) Are there plans to include roation (at least 180°) into the driver? Thanks for hints.

  • User Avatar

    Thanks. It's working the first way with muxing the PADS first.

  • User Avatar

    Thanks. It's working that way.

  • User Avatar

    Thanks for your answer. SD is working in u-boot and in kernel. I know how to update kernel and rootfs from SD but I do not know how to update u-boot from u-boot. Any hint?

  • User Avatar

    Dear support-team, I want to set pin 32 of gpio expander (armstoneA9) to high level in u-boot. I added following lines to function board_init into file board/F+S/fsimx6/fsimx6.c Source Code (2 lines) The pin value still is at 0V while booting (also before kernel is starting). Any idea? Thanks.

  • User Avatar

    Does it mean that if we go into production with 100+ devices we have to load u-boot, device tree and rootfs manually by typing the commands into putty?

  • User Avatar

    Dear support-team, on armstoneA9 sd-card will not be found in nboot. Version: "F&S Nand Loader VN29 built Aug 9 2016 11:40:32" "armstoneA9 Rev. 1.10" I tried with 4GB and 2 GB micro-sd. Any idea? Thanks. EDIT: For now it seems sd-card is not working at all (even in u-boot and in kernel).

  • User Avatar

    Dear support team, we are creating/have created an additional base board for armstoneA9 with power supply and some additional interfaces and connectors. It would be nice if you would tell us where to get the 34 pin ESDCI ICD connector that fits into the armstone RGB connector socket. We would prefer the SMD connector that is also used as J2 on your ASTONE-ADP-EDT1 board. Thanks for any hints.

  • User Avatar

    It's working this way. Great job. Thanks again.