Receiving Multicast Messages

      Receiving Multicast Messages

      Hello,

      we want to implement a kind of discovery tool for our devices. Therefore we tried to implement a simple server at the PicoCOM2 which receives multicast messages. The code we used in the first step is nearly the multicast receive sample for Win CE given by Microsoft. The sender side is implemented using the multicast send sample by Microsoft. We connected a PicoCOM2 with the latest kernel to a desktop pc using a crosslink cable. The results were the following:
      - If the PicoCOM2 sends then the desktop pc receives the multicast message
      - If the pc sends, the PicoCOM2 doesn't receive anything
      - If we connect two desktop pcs via crosslink cable and do the same, the second pc receives the multicast message.

      This leads us to the assumption that the PicoCOM2 has a problem receiving multicast messages.

      In some web forums we found descriptions of a bug in the WinCE network stack that leads to the effect that only special multicast addresses in the form aaa.0.0.bbb work, when in bbb the Bits 0 and 1 are not set. We tried with 224.0.0.4. This doesn't solve the problem.
      What could be the problem? Maybe the NDIS driver?

      Thanks and best regards

      Re: Receiving Multicast Messages

      Please try with unplugged USB device cable (no ActiveSync)

      Does that work?
      F&S Elektronik Systeme GmbH
      As this is an international forum, please try to post in English.
      Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.

      Re: Receiving Multicast Messages

      please describe your environment. what is connected to your picocom2? do you use the picocom2 starterkit?

      I got the same issue and when booting the board without a usb device connection it worked.

      I will setup a test..
      F&S Elektronik Systeme GmbH
      As this is an international forum, please try to post in English.
      Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.

      Re: Receiving Multicast Messages

      Ok, i am able to reproduce that issue on PicoCOM2.

      Please check this thread for new information.
      F&S Elektronik Systeme GmbH
      As this is an international forum, please try to post in English.
      Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.

      Re: Receiving Multicast Messages

      We retried with the starterkit. Now we have the effect, that we get WSA error 10049 (Do not call IP_ADD_MEMBERSHIP with the same group more than once on the same network interface) when calling setsockopt (Sock, IPPROTO_IP, IP_ADD_MEMBERSHIP,...
      If we connect usb active sync, we don't get this error, but we also don't get multicast messages...

      Re: Receiving Multicast Messages

      This problem only resides on PicoCOM2. So maybe you can switch to PicoCOM4.
      F&S Elektronik Systeme GmbH
      As this is an international forum, please try to post in English.
      Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.

      Re: Receiving Multicast Messages

      Hello,

      we tried again with a PicoCOM4 with the newest kernel and the starterkit. The error message mentioned before doesn't appear in this configuration, but we cannot receive multicast messages from a laptop connected via crosslink cable. The other direction works. What is your setup?

      Thanks