U-boot can not read SD-CARD

      U-boot can not read SD-CARD

      Hello
      I get an error message after mmc rescan.

      mmc rescan
      mmc reset on error -18

      u-boot version:

      Source Code

      1. U-Boot 2012.07 (May 05 2013 - 13:58:12) for F&S
      2. CPU: S5PV210@1000MHz
      3. Board: armStoneA8 Rev 1.10 (2x DRAM, 1x LAN, 1000 MHz)
      4. DRAM: 256 MiB
      5. WARNING: Caches not enabled
      6. NAND: 128 MiB
      7. MMC: s5p_sdhci: 0
      8. In: serial
      9. Out: serial
      10. Err: serial
      11. Net: AX88796-0

      SD is an verbatim 8GB SDHC class 4

      Source Code

      1. N-Boot Card Info:
      2. Type: SDHC Card (Block Mode)
      3. Specification Version: 2
      4. Relative Card Address: 7
      5. Operating Frequency: 25653846Hz (High Speed)
      6. Bus Width: 4 bits
      7. Manufacturer ID: 39
      8. OEM/Application ID: PH
      9. Product Name: SDDDS
      10. Product Revision: 3.0
      11. Serial Number: 1887270097
      12. Manufacturing Date: 06/2012
      13. C_SIZE: 0
      14. C_SIZE_MULT: 6
      15. Block size: 512 bytes
      16. Total card size: 256 blocks (0MB)
      17. Partial reads: no
      18. FAT Info:
      19. Start Sector = 2048
      20. Sectors Per Cluster = 16
      21. Reserved Sectors = 1
      22. Number of Sectors = 1024000
      23. Sectors Per FAT = 256

      u-boot is compiled with fs-toolchain-4.7.2-armv6-vfp
      I get the same result with the precompiled u-boot from F&S.
      Booting linux from nand flash. mounting sd-card and read/write to the card works fine.

      Whats wrong?

      regards siggi

      Re: U-boot can not read SD-CARD

      i think this is too short-sighted, because a class 4 is not a high speed card. I think there is a bug in u-boot. Because the card is readable through nboot, the linux (on armstone), several x86 systems(windows and Linux) has no problem with this card. I think there is a timing problem. I know from another project about the sd-card timing that some cards uses the entire width of the tolerance from the sd-card spec. Especially embedded sdcard controller/drivers have problems with those behavioral.
      I know it is not easy to find the reason, why this card doesn't work.
      I will test it with another card.
      regards
      siggi

      Re: U-boot can not read SD-CARD

      Again: we have improved the SD card access and I'm confident that the newer version will read the card without problems. So the problem is already located and solved. We just don't have a release yet.

      i think this is too short-sighted, because a class 4 is not a high speed card.

      Of course it is. See the "Operating Frequency" line in your own nboot output. From the protocol side, there is only a difference between standard speed with max. 25MHz clock and high speed with max. 50MHz bus speed. The speed classes you are talking about don't differ in the bus speed. They all use one of these two bus speeds. They only differ in the speed of the flash chips and the sustainable data rate for reading and writing data.

      Also see the "Total card size" line which shows exactly the error in card capacity that I'm talking about in my other post.

      For now I would recommend using a standard speed card.


      Your F&S Support Team
      F&S Elektronik Systeme GmbH
      As this is an international forum, please try to post in English.
      Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.