LVDS Interface

      LVDS Interface

      Dear Support

      I have this ArmstoneA9 board, not starterkit, no micro SD card.

      I connect Monitor via HDMI and a 7" display via the lvds interface, but I only see 4 penuins Logo on the 7" Display, on the monitor is OK

      Is there any way to "activate" LVDS ,

      Tried "xrandr", but it doesn't work.

      Thanks
      Thanks for your feedback
      How to add "video" atribute to "bootargs" variable on uBoot?
      I am not sure if I did it right
      I powered the board and login with "root"
      then try the command " setenv bootargs console=ttymxc1,video=mxcfb1:dev=lcd,CLAA-WVGA,if=RGB666 "
      then i got "-sh: setenv: not found"
      Do I have to use a terminal program(Putty) to send the command to board?
      thanks
      You should add that variable into uboot.

      1) Connect PC & ARMStone with serial console.
      2) Open a PC serial terminal (Teraterm for example) -> Configure it to open a connection with ARMStone using serial communicacion
      3) Run ARMStone
      4) Stop the linux kernel boot pressing a key. The uBoot prompt appears.
      5) Add your bootargs.

      LVSD Interface with sc card boot:
      fec_mac=00:05:51:08:18:D2 root=/dev/mmcblk0p1 rootfstype=ext4 rootwait rw video=mxcfb0:dev=lcd,LCD-ET070080,if=RGB666 console=ttymxc1,115200

      Where:
      fec_mac=00:05:51:08:18:D2 - Device mac (i think is optional)
      root=/dev/mmcblk0p1 rootfstype=ext4 rootwait rw - Boot mode (see quick start document)
      video=mxcfb0:dev=lcd,LCD-ET070080,if=RGB666 - Video output mode
      console=ttymxc1,115200 - Serial debug output console


      * You can see the uBoot commands with "help"
      * You can print all variables with "printenv"