Problem with FTP

      Problem with FTP

      Hi all,

      I'm having troubles with the FTP on my NetDCUA5.

      Here is my configuration :
      (E)Boot Loader, Version 1.3 (EBOOTVYB_13.nb0)
      NBoot, Version VN12 (nbootvyb_12.bin)
      WinCE7 - Kernel V2.01 (XIPVYB_C7E_V2.0_150129.bin)

      The FTP should be up and running by default but I can't connect (anonymously) on it.

      Here are the only lines that are altered in my registry :

      reg open \Ident
      reg set value Name string CLA_BM_9999_99
      reg open \Comm\ftpd
      reg set value LogFileDirectory string \FFSDISK\www
      reg open \Comm
      reg set value IsEnabled DWORD 1
      reg set value UseAuthentication DWORD 0
      reg set value AllowAnonymous DWORD 1
      reg set value AllowAnonymousUpload DWORD 1
      reg set value AllowAnonymousVroots DWORD 1
      reg set value DefaultDir string "\FFSDISK"
      reg set value IdleTimeout DWORD 300
      reg set value DebugOutputChannels DWORD 2
      reg set value DebugOutputMask DWORD 23
      reg set value BaseDir string \
      reg set value LogSize DWORD 4096
      reg set value LogEnabled DWORD 1
      reg open \Drivers\BuiltIn\DIGITALIO
      reg del value UseAsIO
      reg del value DataDir
      reg del value DataInit
      reg set value UseAsIoA DWORD 0x00000FFF
      reg set value DataDirA DWORD 0x000000FF
      reg set value DataInitA DWORD 0x00000000
      reg save

      What am I missing here ?

      My attempt :

      1) Using the command line :
      >> ftp CLA_BM_9999_99
      << Connected to CLA_BM_9999_99

      Then I get a Timeout

      2) Using Filezilla :
      >> Connection established, waiting for greeting message

      Timeout

      3) Using windows Explorer :
      Timeout
      Hello,

      using this configuration i can't connect at all:(
      (E)Boot Loader, Version 1.3 (EBOOTVYB_13.nb0)
      NBoot, Version VN12 (nbootvyb_12.bin)
      WinCE7 - Kernel V2.01 (XIPVYB_C7E_V2.0_150129.bin)

      Welcome to the Windows CE Telnet Service on FSVYBRID
      Pocket CMD v 7.00
      \> type *.tmp
      \FTPD.tmp:
      [12:00:09 1/1/2006] Starting ftp server
      [12:00:09 1/1/2006] No virtual roots specified
      [12:00:14 1/1/2006] User anonymous logged in
      [12:00:14 1/1/2006] opts utf8 on : Unrecognized command
      [12:00:14 1/1/2006] site help : Unrecognized command
      \>
      And i can't access the board via IE!!!

      Change kernel to "WinCE7 - Kernel V2.02 (XIPVYB_C7E_V2.0_150519.bin)" seems to resolve the problem. I can access the board via IE now!

      I did not investigate the reason in detail, but new kernel contains a lot of QFEs.Please try it again with the latest kernel and a "clean" registry. Does this reslove your problem too?
      By the way, your registering above is stored in a wrong key. All ftpd settings have to be stored under "reg open \Comm\ftpd" *not* under "reg open \Comm\"!
      F&S Elektronik Systeme GmbH
      As this is an international forum, please try to post in English.
      Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.
      Hello,

      I didn't find your version on my page : WinCE7 - Kernel V2.02 (XIPVYB_C7E_V2.0_150519.bin).



      But, I took something else : XIPVYB_C7E_V2.2_150513.bin.

      I also fixed my registry entries, like that :

      reg open \Comm\ftpd
      reg set value LogFileDirectory string \FFSDISK\www
      reg set value IsEnabled DWORD 1
      reg set value UseAuthentication DWORD 0
      reg set value AllowAnonymous DWORD 1
      reg set value AllowAnonymousUpload DWORD 1
      reg set value AllowAnonymousVroots DWORD 1
      reg set value DefaultDir string "\FFSDISK"
      reg set value IdleTimeout DWORD 300
      reg set value DebugOutputChannels DWORD 2
      reg set value DebugOutputMask DWORD 23
      reg set value BaseDir string \
      reg set value LogSize DWORD 4096
      reg set value LogEnabled DWORD 1
      reg open \Drivers\BuiltIn\DIGITALIO
      reg del value UseAsIO
      reg del value DataDir
      reg del value DataInit
      reg set value UseAsIoA DWORD 0x00000FFF
      reg set value DataDirA DWORD 0x000000FF
      reg set value DataInitA DWORD 0x00000000
      reg save

      It now works as expected.

      Thank you very much.
      Hello,
      XIPVYB_C7E_V2.2_150513.bin
      Right, 2.02=2.2 this is an inconsitence in our ordering. We plan to chance this.
      F&S Elektronik Systeme GmbH
      As this is an international forum, please try to post in English.
      Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.