cerhost

      When I run cerdisp on a PicoMOD6 bord an run cerhost on my PC, I can see all units in the network when I click in File->connect in cerhost.
      Doing the same with a PicoMODA9, the PicoMODA9 is not shown.

      As far as I know, cerdisp send periodical broadcasts to allow cerhsot find the board. Is this disables in PicoMODA9?
      Hello,

      no this should work with PicoMODA9 to! I know at least one customer uses cerdisp/cerhost with PicoMODA9!

      - 24BPP does not work with CERDisp!
      - Can you connect via Telnet/FTP?
      - Does network work at all?
      F&S Elektronik Systeme GmbH
      As this is an international forum, please try to post in English.
      Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.
      Network works, I even can connect with Cerhost but I have to input the IP Address manually in the Cerhosts Connect dialog.
      Units with PicoMOD6 are automatically listed in the dialog. This is the only thing that does not work.
      Again, couuld it be that broadcasting is permitted on the PicoMODA9 as default?
      Hm,
      it works now, no idea why it doen't om Monday.

      But I encountered two issues:

      When I run cerdisp right after the PicoMODA9 has booted, I get a lot of error messages on the debug line:

      Source Code

      1. CreateFile() failed -> ERROR COM1:
      2. CheckAutoStart: Version 1.7, LaunchNum = 100
      3. Warning: you are requesting IOCTL_HAL_GET_DEVICE_INFO::SPI_GETPLATFORMTYPE, which has been deprecated. Use IOCTL_HAL_GET_DEVICE_INFO::SPI_GETPLATFORMNAME instead.
      4. Warning: you are requesting IOCTL_HAL_GET_DEVICE_INFO::SPI_GETPLATFORMTYPE, which has been deprecated. Use IOCTL_HAL_GET_DEVICE_INFO::SPI_GETPLATFORMNAME instead.
      5. Application_START
      6. Fonts added: 4 (87) 0 (2)
      7. ENET: LinkState: FULL-DUP, 100Mbps
      8. Exception 'Data Abort' (0x4): Thread-Id=04d6003a(pth=c087b478), Proc-Id=04c5003a(pprc=c086c15c) '6.750.7130.exe', VM-active=04c5003a(pprc=c086c15c) '6.750.7130.exe'
      9. PC=01013c04(???+0x01013c04) RA=0022234c(???+0x0022234c) SP=0016f5d0, BVA=00000000
      10. AppConfig DataMatrixCode is null
      11. AppConfig DataMatrixCode is null
      12. Warning: you are requesting IOCTL_HAL_GET_DEVICE_INFO::SPI_GETPLATFORMTYPE, which has been deprecated. Use IOCTL_HAL_GET_DEVICE_INFO::SPI_GETPLATFORMNAME instead.
      13. ERROR: f:\wince500\platform\netdcu8\src\drivers\cerdisp\cerdisp\cerdisp.cpp line 404: DoBroadcast Unable to broadcast
      14. ERROR: f:\wince500\platform\netdcu8\src\drivers\cerdisp\cerdisp\cerdisp.cpp line 404: DoBroadcast Unable to broadcast
      15. ERROR: f:\wince500\platform\netdcu8\src\drivers\cerdisp\cerdisp\cerdisp.cpp line 404: DoBroadcast Unable to broadcast
      16. ERROR: f:\wince500\platform\netdcu8\src\drivers\cerdisp\cerdisp\cerdisp.cpp line 404: DoBroadcast Unable to broadcast
      17. ERROR: f:\wince500\platform\netdcu8\src\drivers\cerdisp\cerdisp\cerdisp.cpp line 404: DoBroadcast Unable to broadcast
      18. ERROR: f:\wince500\platform\netdcu8\src\drivers\cerdisp\cerdisp\cerdisp.cpp line 404: DoBroadcast Unable to broadcast
      19. ERROR: f:\wince500\platform\netdcu8\src\drivers\cerdisp\cerdisp\cerdisp.cpp line 404: DoBroadcast Unable to broadcast
      20. ERROR: f:\wince500\platform\netdcu8\src\drivers\cerdisp\cerdisp\cerdisp.cpp line 404: DoBroadcast Unable to broadcast


      And sometimes, I get the wring device name listed in the connect dialog of cerhost (PicoMODA694D5836 insead of FSIMX6)
      Do you use latest Image and cer tool (download area)?
      I did not saw this problems using an imx6 platform under EC7!
      F&S Elektronik Systeme GmbH
      As this is an international forum, please try to post in English.
      Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.
      Hm, don't think device name is "incorrect". It is an assembly of "Boardname" + "something else". If you have platformbuilfder you can customize the cerdisp code, it is in the public tree.
      F&S Elektronik Systeme GmbH
      As this is an international forum, please try to post in English.
      Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.
      Hello,

      I restarted testing the PicoMODA9 and I think that the device name is incorrect (or what is the "someting else" part?)

      My Problem is:
      We have several units with a PicoMOD running and sometimes we control these Units with cerhost.
      To identify the unit, wen changed the unitname (HKLM\Ident\Name) because this name is shown in the connect dialog of cerhost.
      With PicoMODA9, this is not possible anymore.

      I do not have a platform builder.
      Hello,
      is it possible that you used a special version of "cerdisp" previously. All versions i found use "SPI_GETBOOTMENAME" as device name (board name + something else). This parameter is passed by the eboot to kernel. So i assume " something else" have to be a mix of bootloader networksettings, think/hope you will find ist in the www.

      Think the only chance to change the name is to customize cerdisp .exe.
      F&S Elektronik Systeme GmbH
      As this is an international forum, please try to post in English.
      Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.
      Ok, think i found the reason. We have had a custom version previously installed on serveral boards.
      Use cerdisp3 will resolve the your problem. But in gerneral we will ship the standard version which use "SPI_GETBOOTMENAME".
      Files
      • CERDisp3.zip

        (6.15 kB, downloaded 148 times, last: )
      F&S Elektronik Systeme GmbH
      As this is an international forum, please try to post in English.
      Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.

      Post was edited 4 times, last by “fs-support_ZU” ().