toolchain wit Debian 64bit

      toolchain wit Debian 64bit

      Hello
      we have tried to set up the toolchain with Debian 64bit.
      We have find two issues and solved it for us; now for your information:

      First we have to install the Library lib32z1 so that make could find the libz.so.1
      And as second issue, at the build process of the Buildroot there is a hard coded link to the BR2_TOOLCHAIN_EXTERNAL_PATH in the fsim6_std_defconfig witch won’t work if you change the location of the toolchain.

      Regards
      Yes, there may be some additional packages required. On Fedora 21, you usually need the following additional packages to compile buildroot:

      glibc (i686), glibc-devel (i686), zlib (i686), wget, perl-ExtUtils-MakeMaker, texinfo, git.

      Here "i686" means the 32-bit version of the package.

      About the path of the toolchain. This is already given as a warning in our FirstSteps documentation (chapter 7.1):

      The cross-compile toolchain is needed to compile U-Boot, the Linux Kernel and the Buildroot
      package. We recommend installing it globally in directory /usr/local/arm. This is the directory
      that is preset in some configuration files. If you use a different directory, you may
      have to modify these configuration settings before being able to build packages, for example
      in Buildroot.


      Your F&S Support Team
      F&S Elektronik Systeme GmbH
      As this is an international forum, please try to post in English.
      Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.
      Changing the location of the toolchain is not possible, that's true. We installed all the tools onto another partition (which is in the backup).
      The easiest solution for us was to set a symlink.

      ln -s /opt/toolchain/fs-toolchain-4.7.2-cortexa5-neonvfpv4 /usr/local/arm

      If this is not possible for you, you can also use mount with the "bind" option.
      Setting a link is also a very good idea. However I would recommend setting it without the fs-toolchain directory, because the fs-toolchain directory is already part of the configuration.

      Source Code

      1. ln -s /opt/toolchain /usr/local/arm


      Your F&S Support Team
      F&S Elektronik Systeme GmbH
      As this is an international forum, please try to post in English.
      Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.