HDMI enabled and hardware acceleration

      HDMI enabled and hardware acceleration

      With help from support, I have enabled HDMI on my board, and just for reference here is the steps I took:

      First I enabled it in arch/arm/boot/dts/armstonea9r2q.dts:
      #define CONFIG_ARMSTONEA9R2_MXCFB0 DISPLAY_LVDS0 #define CONFIG_ARMSTONEA9R2_MXCFB1 DISPLAY_HDMI

      I edited buildroot-2016.05-fsimx6-V3.0/board/f+s/common/etc/X11/xorg.conf to point to /dev/fb0
      After booting, I run:
      echo 0 > /sys/class/graphics/fb0/blank echo 0 > /sys/class/graphics/fb1/blank
      To ensure none of the outputs are blank, I now see my desktop on HDMI output. Hooray! :cool:

      Trying to get support for hardware accelerated video decoding, I ran from the manual:
      gst-launch-1.0 filesrc location=video.avi typefind=true ! aiurdemux ! vpudev ! imxv4l2sink
      Please note there is a confirmed typo in this (correction on the way), the correct command should be:
      gst-launch-1.0 filesrc location=video.avi typefind=true ! aiurdemux ! vpudec ! imxv4l2sink

      But when running this I get:

      Source Code

      1. # gst-launch-1.0 filesrc location=gravity.mp4 typefind=true ! aiurdemux ! vpudec ! imxv4l2sink
      2. (gst-plugin-scanner:585): GStreamer-CRITICAL **:
      3. gst_element_class_add_pad_template: assertion
      4. 'GST_IS_PAD_TEMPLATE (templ)' failed
      5. Can't get caps from capture device, use the default setting.
      6. Perhaps haven't capture device.
      7. display(/dev/fb0) resolution is (1920x1080).
      8. [INFO] Product Info: i.MX6Q/D/S
      9. [INFO] Product Info: i.MX6Q/D/S
      10. ====== IMXV4L2SINK: 4.0.9 build on Feb 15 2017 15:53:16. ======
      11. Setting pipeline to PAUSED ...
      12. ERROR: Pipeline doesn't want to pause.
      13. Setting pipeline to NULL ...
      14. Freeing pipeline ...


      Do we lack VPU hardware support currently?