How to get the Cortex-M4 running.

      How to get the Cortex-M4 running.

      Hello,

      I want to set-up and program the Cortex-M4 Coprocessor on my efusA9x.

      Therefore I downloaded "FreeRTOS_BSP_1.0.1_iMX6SX_F_S_V1.60.tar.bz2" and "gcc-arm-none-eabi-6-2017-q2-update-linux.tar.bz2" and configured everything according "FreeRTOS_BSP_1.01_iMX6SX_on_FS_Boards.pdf" from chapter "3 Installing Toolchain and FreeRTOS BSP".

      The Linux side of my system was build from "fsimx6sx-V2.0.tar.bz2" with "u-boot-2014.07-fsimx6sx-V2.0.tar.bz2". Files comes directly from the F+S server.

      The problem accrued in chapter "4.1 Configuring UBoot" where I tried to configure u-boot.
      I assume with "F&S provides you with a modified UBoot which can make use of the Cortex-M4." the U-Boot from "fsimx6sx-V2.0.tar.bz2" was meant.
      But when I tried to config the u-boot source code conflicts accured.

      4.1
      1. Wrong place. #define in struct

      2. no idea where the offical NXP u-boot source is located (was using git clone github.com/abbasraza/u-boot-imx6q)

      3. That was the only step that seems to be right (/common/Makefile).

      4. there is no “M4 specific configuration” section

      5.skip, line already there (line 34)
      #define M4_BOOTROM_BASE_ADDR 0x007F8000

      ..and so on...

      After all these changes u-boot failed to compile.

      When I compile a demo and try to start it from u-boot ("fsimx6sx-V2.0.tar.bz2"-version):
      efusA9X # tftp hello_world_ddr.bin; cp.b $loadaddr 0x9ff00000 ${filesize}; dcache flush;
      efusA9X # bootaux 0x9ff00000
      Unknown command 'bootaux' - try 'help'

      Therefore, it seems to be that the "fsimx6sx-V2.0.tar.bz2" are the wrong files to get the Cortex-M4 running.

      Do I need another source or what is the problem?

      Post was edited 1 time, last by “BrenkeM” ().

      Well, "F&S provides you with a modified UBoot which can make use of the Cortex-M4." means exactly, that you need a special U-Boot to get access to Cortex M4. The regular U-Boot from the release does not work (yet). Cortex-M4-Support was introduced after the fsimx6sx-V2.0 release, therefore these circumstances. We want to bring out a regular i.MX6 (fsimx6) release at the end of this month and then we will also have a Solo-X (fsimx6sx) release soon after that. This release will contain all parts that are necessary to use the Cortex-M4.

      So if you want to use Cortex-M4 right now, we have to supply a special U-Boot with some additional features. If you can wait another 6 weeks or so, then you can use the upcoming fsimx6sx-V2.1 release.

      Your F&S Support Team
      F&S Elektronik Systeme GmbH
      As this is an international forum, please try to post in English.
      Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.
      I understand. What I need at the moment is a minimal option to run example programs on the Cortex-M4. Please provide me the necessary informations/sources to run examples on the Coprocessor.
      How fix is the release date for the 2.1 version. 5..6..7..8..12 weeks???

      Thanks.
      Yes, sorry. There were some unexpected but important customer specific things to do and in fact some bugs are/were very difficult to hunt down. And last but not least during the summer a few of us were on vacation.

      We are still on it, sorry for the delay. Not long anymore, promise.

      Your F&S Support Team
      F&S Elektronik Systeme GmbH
      As this is an international forum, please try to post in English.
      Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.