[SOLVED] fsimx6 V3.1 Wayland

      [SOLVED] fsimx6 V3.1 Wayland

      The release notes for fsimx6-V3.1 "http://forum.fs-net.de/index.php/Thread/4214-New-Release-fsimx6-V3-1"
      state that "And there is a first defconfig that uses Wayland and Weston instead of X11 as graphics renderer."

      I am assuming that this is configs/fsimx6_wayland_defconfig?

      Attempting to build this does not work.

      make fsimx6_wayland_defconfig

      Results in the following error when the build process reaches cairo
      "In file included from /fsimx6-wayland/buildroot-2016.05-fsimx6-V3.1/output/host/usr/arm-buildroot-linux-gnueabihf/sysroot/usr/include/EGL/eglplatform.h:38:0,
      from /fsimx6-wayland/buildroot-2016.05-fsimx6-V3.1/output/host/usr/arm-buildroot-linux-gnueabihf/sysroot/usr/include/EGL/egl.h:39,
      from cairo-gl.h:130,
      from cairo-gl-private.h:51,
      from cairo-gl-glyphs.c:41:
      /fsimx6-wayland/buildroot-2016.05-fsimx6-V3.1/output/host/usr/arm-buildroot-linux-gnueabihf/sysroot/usr/include/EGL/eglvivante.h:244:22: fatal error: X11/Xlib.h: No such file or directory
      compilation terminated."

      Has anyone else managed to build this?

      In the meantime we have found the reason for this problem. Attached you will find a patch for Buildroot that should fix this behaviour. (Remark: only necessary for fsimx6-V3.1 and fsimx6sx-V2.1; in release fsimx6ul-V2.1 this fix is already included).

      You F&S Support Team
      F&S Elektronik Systeme GmbH
      As this is an international forum, please try to post in English.
      Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.