• Dear Support-Team,

    how do I enable wlan (the onboard wlan device) on armstonea9r2dl ?

    What I tried yet:
    loading kernel modules mwifiex.ko and mwifiex_sdio.ko (I don't know if this are the right ones).
    WLAN seems to be enabled in devicetree.
    wlan0 is define in /etc/network/interfaces.

    I expected to have a wlan0 interface when I check ifconfig.

    Thanks for hints.

  • In our standard configuration, the modules are loaded automatically, so this should be done already when the board has booted. If this is not the case, then this is already strange.

    To load or unload the WLAN modules by hand, simply call

    1. modprobe mwifiex_sdio


    1. modprobe -r mwifiex_sdio

    respectively. This will also load and unload all modules automatically where this module depends on.

    When the module is loaded, then you will have a network device mlan0. You will see this with ifconfig -a. You can activate it with

    1. ifconfig mlan0 up

    Of course you can also set IP and/or MAC address when doing this.

    To be able to connect to a WLAN net, you have to use program wpa_supplicant. Usually this is used in combination with the configuration file /etc/wpa_supplicant.conf. You can either set up the configuration file by hand or you can use wpa_cli to set it up interactively. In both cases you have to switch the rootfs to r/w mode. Then you can start wpa_supplicant with the following command:

    1. wpa_supplicant -B -D nl80211 -i mlan0 -c /etc/wpa_supplicant.conf

    Now you can for example use wpa_cli to scan for available access points, select a network and connect to it.

    Your F&S Support Team

    F&S Elektronik Systeme GmbH
    As this is an international forum, please try to post in English.
    Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.

  • Thanks for your answer. If it's working in the standard configuration I guess it's my matter. I'm using my own kernel and buildroot configuration (base on your standard). I have to look through handling firmware and modules because that's missing in my rootfs. I will tell you later if I solved this issue.