PicoMOD7 + WIN CE 6 Problems on setting COM Index on Serial1-4

  • Hello,

    we have an issue on setting the COM Index in registry for Serial1..4 on a PicoMOD7. (HW V1.0, Kernel 1.09, NBoot VN20, Bootloader 1.14)
    E.g. if we change "Index" from 3 to 5 for \Drivers\BuiltIn\Serial3 and we do a "reg save", after a reboot there is still the old setting with "Index" 3.
    This behaviour is the same on Serial1. --> change "Index" from 2 to 5 --> "reg save" --> reboot --> "Index" 2.

    On PicoMOD6 /(WIN CE 6) we did something similar by changing Serial2 from Index 2 to 5 and it worked.

    We have to use this because our USB Martel Printer doesn''t work anymore on PicoMOD7.
    As far as we understand the Virtual COM-Port driver of this printer takes first available and free COM-Port of the Windows system.

    How do we have to change the Index Values on the PcioMOD7 registry?

    Best regards,
    Klaus Nikolaus

  • Hello,

    because we want to be able to use every serial line as debug line the value "index" is located in the boot hive. Values in the boot hive are not overwriteable. As a workaround you may try to disable the lines by default (Flags=DWORD:4) and load them by demand (ActivateDevice(...)).
    Anohter approach my be to hard code the index of the Virtual COM-Port - what are the settings in detail?

    F&S Elektronik Systeme GmbH
    As this is an international forum, please try to post in English.
    Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.