gstreamer mp4 not working

  • Hello Experts,

    I´ve problems streaming an mp4 videofile.
    Aim is to play the video from QML, but the problems started by trying to play the videofile without QML. I tried

    1. # gst-launch-1.0 playbin uri=file:///Core/Videos/Testvideo20komp.mp4

    and got this error message:

    1. Missing element: MPEG-4 AAC decoder

    1. Missing decoder: MPEG-4 AAC

    1. ERROR: pipeline doesn't want to preroll.
    2. Setting pipeline to NULL ...
    3. Freeing pipeline ...

    Talking to one of your collegues, I added

    1. Target packages -> Audio and video applications -> gst1-plugins-bad -> openh264
    2. Target packages -> Audio and video applications -> gst1-plugins-bad -> voaacenc

    to the menuconfig, did a make clean and builded the rootfs again.
    Trying to play the videofile, I got almost the same error-output:

    Can you please give me the minimum needed package configuration to play a videofile including sound with gstreamer. I did understand, that I first need to be able to run the video without QML, before trying to play with QML MediaPlayer oder QML Video.

    Hope you can help me, as Iam not experienced with gstreamer.

  • I took more time installing some things packages like opencv, opencv2.4 and ended with libav.
    After another make clean, I got this message:

    So far, I see that the missing ecoders/decoders are found now, but the pipeline is not played.
    However, no sign whats wrong now.
    I would be happy if someone can help me.

  • The i.MX6-SoloX CPU (and therefore the efusA9X) does not have a hardware video processing unit (VPU). So all video processing must be done in software. But H.264 (MPEG-4 AVC) decoding in software does not make sense. The computing required to do this is so intense that the result will not have an acceptable frame rate. This is why we did not add any MPEG-4 codecs to our standard configuration in the first place. You can try MPEG-2, there the computation is less complex. But I would guess that even there a full-screen video with smooth playback is not possible.

    In your later examples, you seem to have added the i.MX6 video libraries. But these libraries fail because the VPU hardware that they expect is not present on this CPU. For example the AIUR demuxer is a hardware demuxer that does not work on i.MX6-SoloX. As a fact this SoloX CPU is unfortunately not suited well for audio/video processing.

    So MPEG-4 (either H.263 or H.264) is too complex for this CPU. If MPEG-4 is a prerequisite, then you have a big problem. MPEG-2 may work, so if you can move to MPEG-2, then you may have a chance. You also have to look at the audio codecs. MP2 or MP3 may work, more complex stream types (like MPEG-4 AAC) also produce a much higher CPU load, which is probably not necessary just for having audio.

    By the way, many of these formats require licenses from the MPEG License Association (MPEG-LA) or other entities (e.g. Dolby Laboratories for AC3 a.k.a. Dolby Digital). You are responsible for yourself to request and pay for these licenses. There are no audio or video licenses included with the module.

    Your F&S Support Team

    F&S Elektronik Systeme GmbH
    As this is an international forum, please try to post in English.
    Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.

    Edited once, last by fs-support_HK ().