USB Update dont work

  • Hello


    we update a few NETDCUA5to V3.00 sucessfull but one Board dont connect over USB to NETDCU-USB-Loader.

    In DCUTermi i stopped the Bootprocess with 'S' ans start the connection with DU.


    :> DU

    HW-Watchdog: DELAYED

    Waiting for USB download


    when I turn off the power, appeares "connected at" in DCUTermi


    :> DU

    HW-Watchdog: DELAYED

    Waiting for USB download

    Connected at




    otherwise this board works perfectly also the USB Connection to Win7


    i erase all Application files and reset the Registry with no effect.

    how to make the update


    Best Reguards

    Thomas

  • Were all boards updated with the same setup on the same day from the same person?

    Is the nboot version the same on all boards? You can check with 's' on startup.

    Is the uboot version the same?

    Was a USB-Hub used to connect the NetDCUs?

    F&S Elektronik Systeme GmbH
    As this is an international forum, please try to post in English.
    Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.

  • All boards ar updated with the same Hardware & Software without USB-Hub and from me self


    the good Boards are all delivered and there including older Boards


    her is the debug out from the "bad" board bye normal boot


    Microsoft Windows CE Bootloader Common Library Version 1.2 Built Jul 6 2017 15:40:18

    Microsoft Windows CE Bootloader for NetDCUA5 Built Jan 25 2018

    Portions copyright (c) 2012 F&S Elektronik Systeme GmbH

    Boot Loader, Version 1.5

    NBoot, Version VN13

    HW rev. 1.20


    HW-Watchdog: ON

    System ready!

    Preparing for download...

    Press >S< to step into monitor...

    AUTO BOOT enabled

    Kernel (3377kB) read from flash disk started finished in 630 milliseconds

    INFO: OEMLaunch: Jumping to Physical Address 0x8010B7ACh (Virtual Address 0x0h)...



    Jumping to Kernel @ 0x8010B7AC

    Windows CE Kernel for ARM (Thumb Enabled) Built on Mar 8 2013 at 17:05:33

    INFO:OALLogSetZones: dpCurSettings.ulZoneMask: 0xb

    OAL_IntrInit: TODO

    HW-WATCHDOG: ENABLED


    NetDCUA5 V2.01 - Firmware Init

    Copyright (c) 2013 F&S Elektronik Systeme GmbH

    Build: Feb 19 2015/17:07:56

    FMD: NAND ID:0x92f18095 --> EON: 1GBit (128MB)

    FMD: Block 0 to 16 are locked for boot loader

    OAL: Enable SCU

    I2C: Version 2.5

    INFO: No external RTC found!.

    OAL: RestartReason=Power On Reset

    FMD: NAND ID:0x92f18095 --> EON: 1GBit (128MB)

    FMD: Block 0 to 16 are locked for boot loader

    FSPART: FS partition driver loaded

    BINFS: RegisterVolume - Mounted volume '\BINFS'

    PM-NETDCU: STARTED

    BE2: Version 1.4, ActiveKey = Drivers\Active\01

    PSS: Version 1.1, ActiveKey = Drivers\Active\07

    NI2C: Version 1.0, ActiveKey = Drivers\Active\12

    ENET: Version 01.03, ActiveKey = Comm\ETHNETA

    ENET: Version 01.03, ActiveKey = Comm\ETHNET<2><0><0><0><0><0>BE2: Version 1.4, ActiveKey = Drivers\Active\15

    UART: Version 1.16, Key = Drivers\Active\16

    UART: Version 1.16, Key = Drivers\Active\17

    UART2: Port disabled. Serial debug is on !

    UART: Version 1.16, Key = Drivers\Active\18

    UART3 RS232 Configured

    CID: Version 2.7, ActiveKey = Drivers\Active\19

    CID: Version 2.7, ActiveKey = Drivers\Active\20

    PIF: Version 1.2, ActiveKey = Drivers\Active\21

    Priority256 = 0x00000000 = 0 (Default)

    WaitStates = 0x220f2220 = 571417120 (Default)

    IRQPin = 0x00000068 = 104

    IRQCfg = 0x00000002 = 2

    IOBaseAddr = 0x30000000 = 805306368

    PIF: freq=165069468Hz

    PIF: freq=55023156Hz

    PUI: Version 1.0, Key = Drivers\Active\22

    ERROR: C:\WINCE600\PLATFORM\FSVYBRID\SRC\DRIVERS\UARTIntf\DLL\pif\..\uartintf.c line 1009: UARTINTF not found or damaged. Can't init port.

    PUI: Version 1.0, Key = Drivers\Active\23

    ERROR: C:\WINCE600\PLATFORM\FSVYBRID\SRC\DRIVERS\UARTIntf\DLL\pif\..\uartintf.c line 1009: UARTINTF not found or damaged. Can't init port.

    AIN: Version 1.2, ActiveKey = Drivers\Active\24

    PWM: Version 1.2, ActiveKey = Drivers\Active\25

    EXTRTC: Version 1.1, ActiveKey = Drivers\Active\26

    EXTRTC: No external RTC detected

    I2C: Version 4.2, ActiveKey = Drivers\Active\27

    TCH: Version 1.0, ActiveKey = Drivers\Active\28

    SDHC: Version 1.2, ActiveKey = Drivers\Active\29

    WAV: Version 2.3, ActiveKey = Drivers\Active\31

    BCS: Version 1.4, ActiveKey = Drivers\Active\46

    NSPI: Version 3.0, ActiveKey = Drivers\Active\47

    DIO: Version 2.8, ActiveKey = Drivers\Active\48

    LCD: Version 1.9, ActiveKey = Drivers\Display\LCD

    LCD: Read registry settings from Drivers\Display\LCD

    LCD: Display-Mode 0, Name VGA standard display

    NDCUCFG V 57 started. Platform: NetDCUA

    CheckAutoStart: Version 1.7, LaunchNum = 100

    NDCUCFG Open COM1: at 38400 Baud

    CreateFile() failed -> ERROR COM1:



    Best Reguards

    Thomas




  • Did all boards have the same software version (nboot, eboot) before you updated them?

    Did you update only the kernel or also the bootloaders?


    You can update nboot and eboot over serial in nboot ('d') to the lastest versions.

    F&S Elektronik Systeme GmbH
    As this is an international forum, please try to post in English.
    Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.

  • Hello,


    thanks for the hints.


    we have updated the NETDCUA5 via RS232

    NBoot 15

    EBoot 17


    but there is the same error


    in the bootprocess occures 2 Errors:


    ERROR: C:\WINCE600\PLATFORM\FSVYBRID\SRC\DRIVERS\UARTIntf\DLL\pif\..\uartintf.c line 1009: UARTINTF not found or damaged. Can't init port.

    PUI: Version 1.0, Key = Drivers\Active\23

    ERROR: C:\WINCE600\PLATFORM\FSVYBRID\SRC\DRIVERS\UARTIntf\DLL\pif\..\uartintf.c line 1009: UARTINTF not found or damaged. Can't init port.

    UARTINTF not found or damaged. Can't init port.


    it looks like the file uartintf.c is missing


    Best Reguards

    Thomas

  • Hello,


    "UARTIntf" is an external HW which is connected to the parallel port of NetDCU. The message occur because the interface is not conneted (this may be distressed) but it is not related to your probelem.


    The problem must be located in HW, NBoot or EBoot because when enter "du" there is np kernel loaded at all!

    F&S Elektronik Systeme GmbH
    As this is an international forum, please try to post in English.
    Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.

  • Hello,


    for test we installed different versions of EBoot and NBoot, always the same effect.


    i measure at J7-21

    at bad board 1mV while boot, 6mV when win is started

    at good board 1mV while boot, 245mV by win start


    ist this a hint ?

  • Hello,


    in NBoot there is a similar behavior,

    with connected USB Cable:


    ssssss<0>ssssss


    F&S Nand Loader VN15 built Jul 26 2019 09:29:34

    NetDCUA5 Rev. 1.20

    256MB RAM (1 chip) 128MB FLASH (92f1) 500MHz 512kB L2 A5

    booted primary image from page 4

    serial number not sset

    USB Cable plugged


                                                                                here switch off the power of NETDCUA5

    Connected at ful<0>


    No Connection to NetDCU-USB-Loader 2.4.0


    Is there an Pull-Up/pull-down Resistor on the USB-Lines on the Netdcu ?