Posts by schliz

    Mein NetDCU8 Board ist seit längerer Zeit im Einsatz, seit kurzem friert fast das komplette System ein. Ich habe nun ein Tool laufen, welches die CPU Auslastung testet. Dieses Tool wird noch immer, obwohl alles Restliche eingefroren ist upgedated und es wird eine Auslastung von 1%, wenn ich die Maus (obwohl sie grafisch nicht bewegt angezeigt wird) bewege ca 8% angezeigt.
    Nun möchte ich herausfinden woher dieser Fehler resultiert.
    Als Beispiel kann ich in diesem Zustand zwar auf telnet zugreifen. Es findet zwar eine Verbindung statt:
    Welcome to the Windows CE Telnet Service on NetDCU8


    aber dann bekomme ich keinen Prompt.



    Gibt es irgendeinen Logging Mechanismus oder ein Logging Tool dergleichen?


    Danke
    Georg

    Ist ein BSP für das NetDCU8 board erhältlich?
    Oder gilt das Gleiche wie in Thread: <!-- m --><a class="postlink" href="http://fs-net.de/phpBB2/viewtopic.php?t=1062&highlight=bsp">http://fs-net.de/phpBB2/viewtopic.php?t ... hlight=bsp</a><!-- m --> beschrieben?


    Ich danke für ihre Auskunft.
    Georg

    I would like to update the kernel of a NetDCU8 board:


    The bootloader version is older than the ones we use normally. I tried to updating the kernel using ethernet.
    The output of DCUTermi is different:



    Quote

    DM9K: Wait for LINK ...............................................................................................................................................................................................................................................................


    I start ESHELL.EXE as normal, but no connection is started.


    Question:


    Should it be possible with this bootloader to update the kernel over ethernet?


    Thank you very much.
    Georg

    Do you have any additional information which registry values I have to set?
    Thank you very much.
    Georg

    Quote

    Do I understand this right: the calibration procedure can be started *and* completed, the touch reacts to the crosses shown the display? And the touch also works after calibration (e.g clicking on an icon, dragging a window) and only double-clicks do not work?


    Correct, only double click does not work, or exactly is to slow.


    Quote

    The reason why I ask: you can not take the calibration values from a NetDCU8, write them to the registry on a NetDCU9 and expect the touch to work. Even if touch and display are exactly the same, the calibration mapping works totally different here and the resulting calibration values may look completely different. Even if the calibration procedure is exactly the same and you press exactly the same points on the touch. You have to do a new calibration on the NetDCU9.


    The link for device driver leads to NetDCU4/5/6/8.
    For the touch there seems to be some differences to NetDCU8, I entered all values we did for NetDCU8, but touch does not work at all after entering.


    Which entries are available?
    Thank you.
    Georg[/quote]

    I create a completly new project and do these steps:



    Thank you.
    Georg

    If you build a Win32 Smart Device Application, it is compiling. You get the error for a MFC smart device application.


    Thank you for you information.
    Georg

    Calibration works, but double clicking does not work.


    Which values are read? All settings for NetDCU8?
    If I set MinMove(5) and MaxMove(50) to the default value of NetDCU8, touch is not working any longer. I set it to 1(MinMove) and 1023(MaxMove) and adjusted:


    TouchSamples: 2,3, 7,19
    DeltaXCoordTolerance 1,20,500
    DeltaYCoordTolerance 1,16,450


    Thank you for your help.
    Georg

    I tried to create a simple MFC testproject (NetDCU8 and NetDCU9 Platform). First I compiled it for NetDCU8 everythings working. Than I compiled it for NetDCU9, I got:


    winnetwk.h is only at:

    Quote

    C:\Programme\Windows CE Tools\wce500\NetDCU8\Include\Armv4i

    .


    I searched the web, and I found:

    Quote


    saying:
    ...
    You must add the following components to your OSDesign, even if you do not need those functionalities :


    -AYGShell API Set
    -Windows Networking API/Redirector (SMB/CIFS)
    Otherwise you will have that kind of error during the build :
    fatal error C1083: Cannot open include file: 'winnetwk.h': No such file or directory


    Our kernelversion is: NetDCU9 V0.01
    kernelVersionDate: 10.08.07


    Do you have any hint?


    Thank you very much.
    Georg
    ...

    The link for device driver leads to NetDCU4/5/6/8.
    For the touch there seems to be some differences to NetDCU8, I entered all values we did for NetDCU8, but touch does not work at all after entering.
    As well, there is an additional entry for the driver:


    Are there some changes to NetDCU8?


    Thank you very much.
    Georg

    Thank you for the quick reply!
    I tried Mode 1 and added a key mode1, but there is the same result.


    strange


    Georg

    Unfortunately it still does not work.


    Do you have any additionally information on the SMIVGX key values? Is there maybe something else to adjust?


    Thank you very much.
    Georg

    I tried to set USB 1 to host.


    I entered commands as described:

    Quote

    Reg open \Drivers\BuiltIn\OHCD
    Reg set val PortCount dword 2


    Reg open \Drivers\BuiltIn\USBFN
    Reg set val Flags dword 4
    Reg save


    1. OHCD does not exist, so I created the key.
    It did not work.


    2. I entered PortCount to the existing key OHCI.
    It does not work.


    Dip Switches for host is the same as in NetDCU8.


    Thank you for your information.
    Georg

    We tried to use the same display we use for Board NetDCU8 for NetDCU9.
    We compared all properties, only

    Quote


    the key HKLM\Drivers\Display\SMIVGX\mode100 changed and to set HKLM\Drivers\Display\SMIVGX mode 100 manually

    is different to board 8.


    As output we get inverted colors.


    Do you have an idea?
    Thank you very much.
    Georg

    FYI:


    I used SDK installation to repair SDK. - It did not work.
    I deinstalled SDK completly.
    I installed it again. - Suddenly I was able to enter properties. ?!?
    - strange


    Georg

    I am not able to connect to the NetDCU9 board via Ethernet in VS2005.


    I installed SDK for NetDCU9 board. I created a new project. In VS2005 under Tools/Options/Device Tools/Devices.
    I select NetDCU9 ArmV4I Device: Selecting Properties, I get:

    Quote

    Error retrieving information from user datastore. Property not found.


    Do I have to install something additional?


    Thank you very much.
    Georg


    PS: The same procedure in NetDCU8: in properties I can set TCP Connection Transport and IP address.