Toolchain problem

  • I am using PicoMOD7A. I would like to informe you that when I configure buildroot with picomod7a_min_defconfig and I compile it using fs-toolchain-4.7.2-armv6-vfp it doesn't work, the ubifs fimage generated doesn't work and the PicoMOD7A doesn't start.

    But if I compile it using fs-toolchain-4.6.3-armv6-vfp, everything work correctly.

    Has anybody had the same problem? Is there any solution for this issue?

  • gcc-4.7.2 makes a difference between hardware floating point and software floating point. Therefore it uses /lib/ as linkloader and not /lib/ anymore. However this seems not be used consistently across all libraries and applications, so most binaries will still try to access /lib/ We have solved this by creating a symbolic link from /lib/ to /lib/ This is not strictly correct, but it has worked in all our cases yet.

    You can do this by adding the following lines in the buildroot directory common/final_script_min and common/final_script_std:

    1. # Newer toolchains create, but we also need
    2. if [ -L "${TARGET}/lib/" ] && [ ! -e "${TARGET}/lib/" ];
    3. then
    4. ld=`readlink ${TARGET}/lib/`
    5. ln -s "${ld}" ${TARGET}/lib/
    6. fi

    Your F&S Support Team

    F&S Elektronik Systeme GmbH
    As this is an international forum, please try to post in English.
    Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.