Problem with adding "all" locales (out of memory)

  • Hello,

    I'm using the BSP BSP_FSIMX6SX_WLAN_20190219 for WEC7 on efusA9X and have a problem when trying to add nearly all locales to the OS image.

    I followed this article to add the locales "Adding (all) locales to WEC7"

    When making the runtime image I get the following error message in pass 1, build.log shows:


    Failed to find a range for data of size 1608282

    Error: Ran out of space in ROM for wince.nls size 1608282

    Fatal error hit, exiting...

    The problem seems to be the size of the file wince.nls. When removing some Chinese related LCIDs (language code identifier) from the nlscfg.inf file, the size of the file wince.nls is reduced from 1.608.282 bytes to 691.814 bytes and everything works fine.

    The overall size of the OS image (xip.bin) seems to be not the problem. The size of my xip.bin file was about 54 MBytes when I have experienced this problem. I reduced the size by removing some features to 50 MBytes and got the same error message as with the bigger image.

    I have not modified the memory mapping in config.bib.

    If I reduce the size of wince.nls so that making the OS image works, I get the following information about this file:

    In ce.bib:

    In build.log

    To reproduce this issue, please enable all Catalog Locale items in "FSiMX6SX -> Core OS -> Windows Embedded Compact -> International -> Language -> xxx -> Locale -> yyy" and use the following nlscfg.inf file:

    When removing the last 5 LCIDs (0804, 0C04, 1404, 1004, 0404, all are related to China) the size of wince.nls is reduced significantly and everything works fine.

    Any ideas what to do so that the file fits into the image?

    Best regards,


  • Habi

    Changed the title of the thread from “Problems with adding "all" locales (out of memory)” to “Problem with adding "all" locales (out of memory)”.
  • Hello,

    >> The overall size of the OS image (xip.bin) seems to be not the problem. ...

    I have not modified the memory mapping in config.bib.

    << I assume you have to modify the config.bib. Especially chinese locals increase the image size essentially (10...20MB)!

    F&S Elektronik Systeme GmbH
    As this is an international forum, please try to post in English.
    Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.

    Edited once, last by fs-support_ZU ().

  • Solved.

    The file wince.nls is assigend to the XIPKERNEL section in config.bib. This section has a size of 4 MBytes. After increasing it to 6 MBytes and adapting the other sections accordingly building the image worked.

    The origianl settings in config.bib:

    1. XIPKERNEL 80220000 00400000 RAMIMAGE
    2. NK 80624000 03E00000 NANDIMAGE
    3. CHAIN 80620000 00004000 RESERVED
    4. RAM 80620000 0F9E0000 RAM ; size= (0x90000000-0x80620000)
    5. XIPSCHAIN=80620000

    And my changes:

    1. XIPKERNEL 80220000 00600000 RAMIMAGE
    2. NK 80824000 03C00000 NANDIMAGE
    3. CHAIN 80820000 00004000 RESERVED
    4. RAM 80820000 0F7E0000 RAM ; size= (0x90000000-0x80820000)
    5. XIPSCHAIN=80820000