Nboot stuck on "select action"

  • Hello, I have a problem with Nboot being stuck on the "Please select action" screen when using Tera Term and pressing 's' while powering on.

    If I'm quick enough, I can "start" the action (provided I started by pressing 's', then 'd'/ 'E'/'B'), but the device works only for a fraction of a second and then stops responding.

    This is what I've done until the Nboot stuck:

    I booted to Nboot and flashed U-boot using Tera Term (ended with sucess and a checksum), then immediately wrote commands:



    setenv installcheck ram@80300000,mmc,usb,tftp

    setenv updatecheck mmc,usb,tftp

    After the "updatecheck" command, the device responded with something like "setenv command not existing" (cannot remember exactly) and refused to respond.
    Then I tried to load U-boot again and while it seemed it was loading, cursor ended stuck on the line "NAND: " (there was no value).

    So I went to Nboot and tried to reflash U-boot but all I got was the behavior described at the beggining.

    Is the Nboot broken ? How to fix it?

    Thanks for help

  • Hello,

    it seems the NBoot is not the problem. The NBoot get "stucked" because it does not find the U-Boot. You see it in the first line of your quotation "no Bootloader found, flash is empty". If the NBoot doesn´t find the U-Boot it goes into the NBoot menu, so this is correct.

    Can you please try to install U-Boot from NBoot. If you are using TeraTerm you need the following commands.

    1. Press 'd' to download the file
    2. Then "File/Send file..."
    3. Choose your U-Boot file and don´t forget to select the binary check box in the lower left of the window.
    4. Press 'f' to save and 'x' to execute

    If this does not work please share the whole debug messages to analyze.

    Your F&S Support Team

    F&S Elektronik Systeme GmbH
    As this is an international forum, please try to post in English.
    Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.

  • As I described before, whole NBoot freezes just upon the start. That means, anything I try to press or do the upload - it just does not work because terminal (Tera Term) hangs after few milliseconds. I know for a fact that it froze, because before (the steps I described in the post earlier), there was this "Please select action" screen popping up repeatedly. Now it displays just once and then nothing.

    I am still sometimes able to let the terminal respond to an action, but that only happens when I remove and insert battery and on the first power button press, I have ~0.5second to do this. Then everything freezes again, even in the middle of an action.

    How can I provide you these debug messages, please? Quoted messages are only messages I get from serial port. I don't have the USB on my board; only serial port and something that seems to be a JTAG? (10 pin connector, 2x5 pins).