LAN connection issue, cannot get ETH_A and EETH_B to work

  • Hi,

    We have ordered 4 Starterkit PicoCore™MX8MN Linux boards and we're having trouble connecting via ETH_A and ETH_B on two of the four boards.
    Two boards work fine and we can download our own code and it works as expected.

    On the other two boards I'm having trouble getting the LAN ports to work. The Ethernet Activity and Link Leds are not blinking even when a network cable is connected.
    At first I thought it was our image but I have tried to revert back to the recovery image given here: flash from zero PicoCore imx8mn ddr3 and the leds are still dark.
    After installing the recovery image i also tried running tftp via the debug terminal but got the following:

    1. PicoCoreMX8MN-DDR3L # tftp uboot.fs
    2. Using ethernet@30be0000 device
    3. TFTP from server; our IP address is
    4. Filename 'uboot.fs'.
    5. Load address: 0x40480000
    6. Loading:
    7. *
    8. ARP Retry count exceeded; starting again

    Does this mean that the LAN ports are not workling and that we should return the boards?
    I have filed an RMA issue for this (Thursday 27th October 2022) using the RMA page but I have not gotten a response yet.

    Please let me know if you need some more information.

    with regards,



  • Hello,

    you should have received an E-Mail with all the necessary RMA documents attached to send the two boards in.

    Did you receive such an E-Mail?

    When the boards arrive we will look into the problem from hardware and software perspective.

    Your F&S Support Team