DCUterm RS232 port failing state

  • Hello.

    Since a very long time, I use the DCUTerm program V1.0011 (currently available for download) and I face a problem with the RS-232.

    If I run hyperterminal on COM1 for example and quit the program, then I run DCUTerm, and when I connect the port I receive the following error:
    "Fatal error while reading comport data. Error: %d"

    Then I am stuck and the only way to be able to use DCUTerm is by rebooting my computer. Even a reboot is not enough, I need to stop and restart the computer with power off in between. It seems that it screws up the UART chip on the computer.
    I have seen the same problem on another computer so it seems to be happening in all of these situations where we use hyperterminal and DCUterm switching from one program to another.

    Can you please test this and confirm this problem on your side?

    Thank you.

  • Quote from "benber"

    I have the problem too. In my case it is enough to reboot the computer.

    Yes to me this is also the only solution that I have. But to be honest, this is not a real solution. It clearly shows that there is a problem with DCUterm and it should be addresed by F&S. I am still eagerly waiting for the fix, as I am fed up with having to reboot my computer two times per day due to this bug.

    Can F&S confirm to be working on the fix?

  • Well, in fact the bad guy in this scenario is HyperTerm, which is a really bad piece of code. When using it we have hanging PCs all the time. Try to use PuTTY instead. I'm switching between PuTTY and DcuTerm all the time and don't have any problems.

    F&S Elektronik Systeme GmbH
    As this is an international forum, please try to post in English.
    Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.