Discspace Problem with 1GByte Flash

  • Hi,

    I'm using an efusA9X board with 1 GByte flash. At delivery status it was partitioned as following

    OS-image: 128 MByte

    FFSDISK: 128 MByte

    Second: 768 MByte

    In EBoot (version 1.4) I changed the partitioning of the flash drive using the command P:

    OS-Image: 128 MByte

    FFSDISK: 896 MByte (Fat)

    Second: 0 MByte (Extended)

    According the messages in EBoot this worked fine. Even after powering off/on EBoot shows

    the correct partitioning when using the command I:

    Size of area for OS image: 128 MB

    Size of FFSDISK: 896 MB

    Format of FFSDISK: FAT

    But under Windows the Storage Manager shows:

    Capacity: 509.50 MB


    - Part00: 515 Sectors

    - Part01_*: 65.537 Sectors, driver fs_binfs.dll

    - Part02_*: 194.624 sectors, driver exfat.dll

    It seems that the Windows sees only about the half of the available 1GB space which is Part00 and Part01.

    Part02, which should have size 0, got the other half of the available memory. The information Windows shows

    differs from what EBoot shows.

    Eboot shows the whished values, but Windows has its own idea about this.

    Below I added the terminal logging of the session in which I partitioned the drive.

    I could try to repartition the flash drive using Windows, but for production we would like to use

    EBoot to configure the device.

    Any ideas what is going wrong there?

    Best regards,


    Here the logging of the session in which I partitioned the flash drive.

  • Okay, I think I know why Windows shows just about 512 MByte of disk space.

    We use the board efusA9X-V8-W13. I think this board has 512 MByte flash.

    I got confuse with the message from Eboot shown by the command P (see logging above):

    According to EBoot this device has 1 GByte.

    I'm assuming that Eboot is wrong here.

    Is this a bug in EBoot or do I miss here something?

  • Hello,

    >> I'm assuming that Eboot is wrong here.

    << I never saw such an error! Are you sure using efusA9X-V8-W13 (checked by serial number info at our homepage)?

    Which size is shown for ffsdisk under cmd.exe?

    Try reset bootloader setting "C" (afterwards you have to reconfigure the board).


    - Part00: is for EBOOT, NBOOT, Boot BMP, PSD

    - Part01: is the kernel partition (fs_binfs.dll)

    - Part02: is the user flash, ffsdisk (exfat.dll)

    ... further partions, e.g. ffsdisk2 (exfat.dll)

    F&S Elektronik Systeme GmbH
    As this is an international forum, please try to post in English.
    Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.

  • Thank you very much for clarifying what the partitions are for.

    >> Which size is shown for ffsdisk under cmd.exe?

    The command ">dir \FFSDISK" shows that about 340 MBytes are free. I have installed about 25 MBytes in this directory, so that

    in total in FFSDISK are about 375 MBytes available.

    Together with the 128 MByte for the OS-image (Part01) this is pretty close to 512 MByte.

    >> Are you sure using efusA9X-V8-W13 (checked by serial number info at our homepage)?

    I checked the serial number in your homepage, and yes, it is efusA9X-V8-W13.

    >> Try reset bootloader setting "C" (afterwards you have to reconfigure the board).

    Currently I have no access to these boards since colleagues are performing tests with them. But as soon as a board is available again

    I can try this. But I'm not very optimistic that this changes anything, we have two boards of this kind and both showed the same

    behavior in Eboot (1024 MByte free space for partitioning).

  • Okay, in the meantime I got two further efusA9X boards. Even after resetting the bootloader via the 'C' command Eboot showed that the boards have 1 GByte of flash. Nboot shows the expected 512 MBytes, see the following logging:

    Unfortunately it is not possible to enter the size of the last partition "SECOND" manually, Eboot assigns automatically the not used space to it. This means that I have two options:


    - Kernel: 128 MByte

    - FFSDISK: 1024-128 = 896 MByte

    - SECOND: 0 MByte (automatically assigned by Eboot).



    - Kernel: 128 MByte

    - FFSDISK: 512-128 = 384 MByte

    - SECOND: 512 MByte (automatically assigned by Eboot).

    In both cases Eboot tries to access not existing memory to make the partitioning and to format the partitions. Which one is less worse, a) or b)?

    I tried both. When doing b) the installed kernel did not start (kernel stopped at the second BE2....), after resetting the device Eboot was lost. When doing a) the kernel started, also after powering on/off. So option b) seems to destroy at least less than a).

    But independent weather a) or b) is done, I always have to install Eboot after doing the partitioning with the parameters shown in a) and b). Is this normal? If I partition the flash and power the device off/on, Eboot is lost (Nboot shows the command line automatically with the hint that there is no Eboot). After flashing Eboot in Nboot via the serial interface. I can use Eboot to install the OS-image.

    Is this a normal behavior or can this be caused by the problem that Eboot works with the wrong size of the flash?

    Nboot: VN32

    Eboot: Version 1.4