Linux boot process gets stuck

  • Hello,

    I'm starting to use PicoCOMA9X as a replacement of PicoCOMA5 (which we are using for years). Our board is supposed to be PicoCOMA9X-V3I-LIN hw rev. 1.10.

    NBoot (VN39) and U-Boot (2018.03) are still the original ones.

    Following the documentation I uploaded to module's flash these bins (original files from VM Fedora 27 - fsmix6sx-B2019.11):




    After this upgrade and reset, linux starts to boot but it seems that it gets stuck.

    It seems that boot stops somewhere between SDHC controller and USBIFS initializations.

    In U-Boot UBIFS seems to be ok (at least ubifsmout and ls ubi 0 commands are successful) and so does SD card.

    Do you have any advice what should I try?

    All kernel messages are in attachment.

    Thank you,


  • Hello,

    There are some i.MX6SX SoC variants without GPU.

    When the Kernel tries to initialize the GPU here, the board hangs.

    This is a known issue and the Device Tree GPU node will be disabled automatically by Uboot in future releases.

    For now you will have to disable the GPU node by hand.

    Please try to add the following code to your picocoma9x.dts Device Tree:

    1. &gpu3d {
    2.     status = "disabled";
    3. };

    Your F&S Support Team

  • I tryied to do it, but the compiler fails to make dtb.

    I'm not familiar with dts structure and syntax.

    1. Error: arch/arm/boot/dts/picocoma9x.dts:609.1-7 Label or path gpu3d not found
    2. FATAL ERROR: Syntax error parsing input tree
  • Your welcome.

    I noticed there is also a define at the beginning of the device tree that adds this change for you.

    Just comment out the define CONFIG_PICOCOMA9X_GPU like this and it should work too:

    1. //#define CONFIG_PICOCOMA9X_GPU

    Your F&S Support Team

  • Hello again.

    Comment CONFIG_PICOCOMA9X_GPU works ok, but I am not able to see GUI in linux.

    PicoCOMA9X is in startekit equipped with 800x480 display. U-Boot works with this display without problems, I can switch U-Boot console to LCD and I see linux logo and then all the booting messages. But as soon as boot is finished, display turns off.

    Is there something else I should change in picocoma9x.dts for this PicoCOMA9X without GPU hw?



  • Hello,

    are you running X11?

    If so you have to adapt the file /etc/X11/xorg.conf

    mount -o remount,rw /

    vi ]/etc/X11/xorg.conf /

    and change the section "Device" to the following to disable GPU support:

    1. Section "Device"
    2.     Identifier  "Kernel Framebuffer Device"
    3.     Driver      "fbdev"
    4.     Option      "fbdev" "/dev/fb0"
    5. EndSection


    mount -o remount,ro /

    and reboot the board.

    Now the display should work.

    Your F&S Support Team

  • Hello,

    I tried to change xorg.conf but X11 does't start correctly anyway.

    There is an error: Failed to open authorization file "//.serverauth.243": No such file or directory

    Complete Xorg.0.log is attached.

    Except for the changes recommended earlier in this thread, filesystem and kernel are default (fsimx6sx_std_defconfig) - created from buildroot fsimx6sx-B2019.11.

    Thank you.


  • Hello Kor,

    the display should be working despite the "error" message. X11 is searching for the .serverauth.$$ in the home directory. The rootfs is read only and therefore the file won't ever be located there. You can change the following line in the /usr/bin/startx script:


    and delete

    XAUTHORITY = $HOME/.Xauthority

    (the XAUTHORITY variable contains the path /var/run/.Xauthority)

    in the if branch. This should clear the error messages. Since my test setup is working either way (with or without the changes in startx), I can't really tell if this is helping you if your display is still not working. Consider this a quick test.

    Your F&S Support Team

    F&S Elektronik Systeme GmbH
    As this is an international forum, please try to post in English.
    Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.

  • Hello,

    I tried to change starx as you adviced, but there seem to be no difference in behaviour. While linux is booting, display shows tux logo, but as soon as X11 windows start display turns white and nothing else happens.

    Anyway as X11 should have been only for test purpouses, I switched to the window system we used in our former devices - Nano-X windows (via framebuffer as our module doesn't have GPU) and using this display works ok.

    So the conclusion is that I don't know why X11 doesn't work, but display interface and framebuffer are ok.

    Thanks for advices.