Font Anti-Aliasing not working?

  • I need Hi-Quality text output on display, so I turnd to turn on CE's built in anti aliasing for fonts.

    HKEY_LOCAL_MACHINE\SYSTEM\GDI\fontsmoothing set to 1

    But it does not seem to work, as the output still looks the same.


  • Hello,

    i dont perform any registry modifications but i set the LOGFONT member "lfQuality" to "ANTIALIASED_QUALITY" and it works! So i suggest your font or the system font does not support anti aliasing or the setting you do are not correct / uncomplete.

    I think the best and fastest way may be to create your own font handles, e.g. by:

    F&S Elektronik Systeme GmbH
    As this is an international forum, please try to post in English.
    Da dies ein internationales Forum ist, bitten wir darum, Beiträge möglichst in Englisch zu verfassen.